RapidIdentity Product Guide: Legacy UI

System Requirements
  • Windows 2012R2 Server (or higher)

    Note

    The server on which the agent is running must have Windows Management Framework (WMF) 5.1.

  • Windows PowerShell and WinRM 3.0 or newer

  • Internet Information Services (IIS) 7 or newer

  • .NET Framework 4.x or higher

  • Microsoft Online Services Sign-In Assistant

  • MSOnline PowerShell for Azure Active Directory

  • SharePoint Online Management Shell (Only required for SharePoint Online support)

  • Must have access to:

    • Package Provider: NuGet

    • Up-to-date modules:

      • PowerShellGet

      • MSOnline

Note

The RapidIdentity Connect Exchange Administrative Web Service Agent exposes the Powershell based Exchange ManagementAPI as a web service for consumption by the Exchange and Office 365 adapters.